2.24 data entry strange error

Hi Guys,
When i create a data set and assign to orgunit then go to data entry. the period is blank. we need to click on prev year and then next year to do data entry for aug 2016.

This happens also in demo site. i created a data set jl_test. In browser console it show categories error even though the data element is has no category combo, just default one.

Regards,

John

Browser console:

image

after clicking on prev year and next year we can see the period and also data element for data entry.

image

I have also seen this.

I suppose in general the aggregate data entry module is due for a makeover in the same way as the new Maintenance module though, so maybe we can wait for that. The question is how soon this can fit in the overall roadmap. A makeover would hopefully also include automatic selection of a dataset when there is only one that is applicable (which would be nice to have throughout the system for dropdown selections).

image

image

···

On Mon, Oct 10, 2016 at 8:56 AM, John Lewis johnlewis.hisp@gmail.com wrote:

Hi Guys,
When i create a data set and assign to orgunit then go to data entry. the period is blank. we need to click on prev year and then next year to do data entry for aug 2016.

This happens also in demo site. i created a data set jl_test. In browser console it show categories error even though the data element is has no category combo, just default one.

Regards,

John

Browser console:

after clicking on prev year and next year we can see the period and also data element for data entry.


Mailing list: https://launchpad.net/~dhis2-devs

Post to : dhis2-devs@lists.launchpad.net

Unsubscribe : https://launchpad.net/~dhis2-devs

More help : https://help.launchpad.net/ListHelp

Knut Staring

Dept. of Informatics, University of Oslo

Norway: +4791880522

Skype: knutstar

http://dhis2.org

Hi John,

okay can confirm that. It is an issue with the maintenance app and the model validation. We will fix:

https://github.com/dhis2/maintenance-app/issues/262

best regards,

Lars

image

image

···

On Mon, Oct 10, 2016 at 8:56 AM, John Lewis johnlewis.hisp@gmail.com wrote:

Hi Guys,
When i create a data set and assign to orgunit then go to data entry. the period is blank. we need to click on prev year and then next year to do data entry for aug 2016.

This happens also in demo site. i created a data set jl_test. In browser console it show categories error even though the data element is has no category combo, just default one.

Regards,

John

Browser console:

after clicking on prev year and next year we can see the period and also data element for data entry.

Lars Helge Øverland

Lead developer, DHIS 2

University of Oslo

Skype: larshelgeoverland

lars@dhis2.org

http://www.dhis2.org